\Device\Harddisk2\DR12

28. November 2004 | Tim Springer

Er hat mich über Monate fast zur Weissglut getrieben. Heute morgen habe ich ihn gekillt.

  
Problem
Bei jedem Systemstart werden kurz vor Ende des Boot-Prozesses (Benutzer hat sich eingelogged, Desktop ist bereits sichtbar) diverse Fehlermeldungen nach folgendem Schema angezeigt:

“Es befindet sich kein Datenträger im Laufwerk. Legen Sie einen Datenträger in Laufwerk DeviceHarddisk1DR13 ein.”

Der Absender der Fehlermeldung (im Titelbalken der Fehlermeldung einsehbar: “xyz.exe – Kein Datenträger”) sind verschiedenste Programme, denen aber gemeinsam ist, dass sie beim Systemstart automatisch gestartet werden. Die Nummern nach “Harddisk” und “DR” variieren ebenfalls, während hinter “Device” keine Nummer steht (wie dies eigentlich normal wäre).

Als Reaktionsmöglichkeit werden die Buttons “Abbrechen”, “Wiederholen” und “Weiter” angeboten. Welche Button angeklickt wird scheint allerdings keinen Unterschied zu machen, und das System läuft anschliessend problemlos. Der Fehler wird in der “Computerverwaltung” unter Ereignisanzeige > System mit der Quelle “Application Popup” gelogged; dort ist auch der exakte Text und die auslösende Applikation nachvollziehbar.

Der betroffene Rechner ist ein HP Pavilion K351.CH unter Windows XP Professional mit Service Pack 2 und allen “Wichtigen Updates” von Microsoft.

  
Lösung
Das Problem dürfte mit dem Kartenleser (Medion Flash XL) für Compact Flash, Memory Stick, MultiMedia und SmartMedia zusammenhängen, der im HP Pavilion installiert ist. Es tritt offenbar in dem Moment auf, wo diese Kartenleser als Laufwerke gemountet werden. Folgende Prozedur hat das Problem gelöst, wobei ich nicht mit Sicherheit sagen kann, ob alle Schritte erforderlich sind.

  1. “Computerverwaltung” öffnen (unter Start > Einstellungen > Systemsteuerung > Verwaltung).
  2. In der “Datenträgerverwaltung” für alle Wechselmedien-Laufwerke (DVD, CD, Speicherkarten) einen neuen (temporären) Laufwerksbuchstaben vergeben (Festplatten nicht ändern). Anschliessend wieder die (endgültigen) Laufwerksbuchstaben zuweisen, wobei die Buchstaben in alphabetischer Reihenfolge nach folgender Priorität vergeben werden: a) Festplatten, b) DVD/CD-Laufwerke, c) Kartenleser.
  3. Neustart des Systems.
  4. “Computerverwaltung” erneut öffnen.
  5. Im “Geräte-Manager” und “Laufwerke” alle Kartenleser per Kontext-Menü (rechte Maustaste) kurz deaktivieren, dann wieder aktivieren.
  6. Neustart des Systems.

Den entscheidenden Hinweis verdanke ich einem Post im Zerobyte Forum.

  
Ähnliche Probleme und Lösungsansätze
Das Web ist voll von ähnliche Fehlerbeschreibungen und unterschiedlichsten Lösungsvorschlägen. Da die oben beschriebene Lösung möglicherweise nur für mein spezifisches Problem hilft, hier eine kurze Zusammenfassung der häufigsten Fehlerbeschriebe und Lösungsvorschläge:

  • Das Problem wird häufig im Zusammenhang mit Sicherheitsprogrammen (z.B. Firewalls) erwähnt (die ja in der Regel ebenfalls als Auto-Start-Programme installiert sind), scheint aber nicht herstellerspezifisch zu sein (Zone Alarm, McAfee…)
  • Weitere häufig genannte Auto-Start-Programme sind die Office-Leiste und Apple QuickTime.
  • Die Fehlermeldung erscheint erstmals nach einer unbedeutenden Manipulation am System (meist Installation eines Programms).
  • Vereinzelt wurde der Fehler nicht beim Systemstart, sondern beim Starten gewisser Programme (Microsoft Office, Gimp, Microsoft Money) gemeldet.
  • Vereinzelt scheit das Problem nicht nur mit Speicherkartenlesern, sondern auch mit USB-Memory-Sticks zusammenzuhängen.
  • Eine Vermutung, dass es sich um ein Problem der Zugriffsrechte handelt (Programm wird von einem Administrator installiert, aber unter einem Nicht-Administrator ausgeführt), hat sich nicht bestätigt.
  • Eine abenteuerliche Lösung, welche das Leeren des “Prefetch”-Ordners von Windows empfiehlt, hatte bei mir keinen Erfolg.
  • Die Trivialerklärung in der Microsoft Knowledge Base (System möchte auf ein bestimmtes Wechselmedium zugreifen, das sich nicht im Laufwerk befindet) hilft ebenfalls nicht weiter.
  • Der Einsatz von msconfig.exe brachte keine Lösung.

29 Kommentare

  1. Kommentar von Hans

    Die beschriebene Methode Funktioniert NICHT bei mir.

    Ich habe auch das lehren der prefetch directory versucht. Das funktioniert gleich, ABER am nächsten Tag war die Fehlermeldung leider wieder da!

    Ich hoffe Microsoft nimmt sich dieses Problem mal an. Es ist bestimmt ein Microsoft Fehler.

    Hans


  2. Kommentar von Rainer Kanter

    Hallo, ich bin froh bei diesen Tipps gelandet zu sein, denn auch mich hat dieser Fehler seit über einem halben Jahr beschäftigt. Die vorgeschlagenen Schritte, die Laufwerksbuchstaben zu ändern und dann wieder herzustellen hat bei mir nichts gebracht. Ich habe alle Kartenleser im Gerätemanager deaktiviert-ich hoffe die Ruhe hält eine Weile.


  3. Kommentar von Josef

    Bei mir hat es funktioniert. Ich habe zusätzlich noch darauf geachtet, dass der Laufwerksbuchstabe F: nicht vergeben wurde (insbesondere nicht für den Kartenleser), weil ich nämlich irgendwo im Internet gelesen hatte, dass hier auch noch ein Zusammenhang bestehen könnte. Ob es so ist weiss ich nicht sicher. Aber jetzt läuft es wieder.


  4. Kommentar von Peter

    Hi,

    die erste Lösungsmöglichkeit hat nicht ganz funktioniert.
    Aber nach Hinweisen aus diesem Thread:
    http://www.computerbase.de/forum/showthread.php?t=85569

    habe die Laufwerksbuchstaben des Cardreaders weiter nach hinten gelegt u: – x:

    Dann ging es.


  5. Kommentar von Arnd

    Hallo, ich habe die 4 Cardreader des Aldi PC statt als Laufwerksbuchstaben jetzt unter leeren NTFS-Verzeichnissen ‘liegen’. Fehler ist weg.
    Bei mir gings so: via Start-Systemsteuerung- Verwaltung- Computerverwaltung- Datenträgerverwaltung- re.Maustaste ‘Laufwerksbuchstaben ändern’- hinzufügen- in leerem NTFS Ordner bereitstellen- danach re.Maustaste ‘Laufwerksbuchstaben ändern’- entfernen – entsprechenden Laufwerksbuchstaben entfernen
    Gruesse Arnd-at-Merlevede.de
    (für richtige email: -at- durch @ ersetzen)


  6. Kommentar von Jonny

    Ich hatte das selbe unter W2K und der Explorer war nach dem Systemstart immer offen. Bei mir war der DVD-RAM Treiber meines LG Brenners “schuld”.
    Wenn der installiert ist, dann exitiert ein Laufwerk in dem kein Datenträger drin ist, was zu den genannten Problemen führt.


  7. Kommentar von sunfish

    Hallo,
    DANKE 🙂

    Bei mir gab es plötzlich Probleme mit dem Brennen von CD’S: “Es befindet sich kein Datenträger im Laufwerk.”
    Jo – ein Umbenennen der CD Laufwerke hat das Problem geheilt. Hich habe deine Reihenfolge verwendet: a) Festplatten, b) DVD/CD-Laufwerke
    Offensichtlich kommt Windows manchmal mit dem Erkennen von Laufwerken und der Zuordnung zu den Kaufwerksbucgstaben (intern) durcheinander.

    Noch ein Hinweis:
    Bei Windows XP darf offensichtlich das AUTOPLAY für das Brenn-CD-Laufwerk nicht “disabled” sein. Also Autoplay wieder aktivieren, wenn es mit den Powertoys ausgeschaltet wurde.


  8. Kommentar von Wolf Kronebach

    Nach der Skype – Installation stellte sich die Fehlermeldung “Kein Datenträger” ein.
    Der Tipp: unter C:/Dokumente und Einstellungen/mein Benutzername/Lokale Einstellungen/ Temp den gesamten Inhalt löschen (Papierkorb leeren nicht vergessen!), dann unter C:/Windows/Prefetch den gesamten Inhalt markieren und löschen (auch wieder Papierkorb leeren nicht vergessen) Windows Neustart – war sehr gut, jetzt kommt keine Fehlermeldung mehr!!!! (die Prefetch-Optimierung ein Datei-Cache. sie merkt sich, welche Dateien von einem Programm beim Start zusätzlich angefordert werden und darf normalerweise gelöscht werden!)


  9. Kommentar von Guenter

    Hi,
    bei mir war es ein Erfolg. Allerdindings habe ich nur ein mal die Reihenfolge,
    DVD / DVD / Kartenleser und die Laufwerke mit neuen Buchstaben, in alphabetischer, versehen. Seidem: Ruhe.

    Alte Reihenfolge: Kartenleser / DVD / DVD und Buchstabensalat.


  10. Kommentar von Alexej

    Nach dieser Datei suchen und löschen! QuickTimeFavorites.qtr

    Funktioniert einwandfrei 🙂


  11. Kommentar von Ferdi

    Guten Morgen, dieser Fehler kommt auchn davon, wenn man eine CD einlegt und wenn sich das Programm öffnet und man zuerst die CD entfernt und somit das Programm schließt. Bitte immer erst das Programm schließen und erst dann die CD entfernen und der fehler ist weg. Eine falsche Einstellungen im Firewall haben mit Schuld daran.
    Viele Grüße
    Ferdinand


  12. Kommentar von David McLion

    Der Hinweis auf den USB Stick hat das Problem gelöst. Normalerweise kann ich innerhalb meines Netzwerks die Sticks wie ein Diskjockey verwenden – nämlich immer dann, wenn ich Probleme mit dem Netzwerk habe oder es noch nicht eingerichtet ist (z.B. neuer Computer). Ich hatte alles versucht: Laufwerksbuchstaben geändet, frühere Systemwiederherstellungspunkte gesetzt – nichts half. Dann habe ich den USB Stick eingesteckt – und nach 5 Stunden Stress war alles wieder im Lot. Vielen Dank für diesen Hinweis. Möge er anderen ebenfalls dienlich sein.


  13. Kommentar von David McLion

    Wichtiger Kommentarnachsatz
    Nachdem ich den USB Stick wieder herausnahm und XP neu startete, hatte ich wiederum das gleiche Problem. Nun habe ich sämtliche Laufwerke umbenannt (ausser C). Auch das half nichts. Ob ich den Stick hineinsteckte oder nicht, der Fehler trat immer wieder auf. Heute habe ich nun noch eins versucht:
    Mit dem Programm “Hardware sicher entfernen” in der Taskleiste unten rechts habe ich alle Wechseldatenträger, die sich im Laufe der Zeit angesiedelt hatten, gelöscht. Und nun war das Problem endlich gelöst. +++


  14. Kommentar von Der Junge

    Jawoll – David!!
    “Hardware sicher entfernen” in der Taskleiste hat mein allernervigstes Problem nach dem Hochfahren des Computers endlich beseitigt!

    Vielen Dank für deine Hilfe……hatte mir im Netz über einen sehr langen Zeitraum schon echt nen Wolf gesucht.


  15. Kommentar von Toast

    Moin!

    Per “Hardware sicher entfernen” in der Taskleiste, hat es nicht geklappt. Nach einem Neustart ist das Problem nicht beseitigt. Dagegen funktioniert die Anleitung, die in diesem Blog beschrieben wurde. GIMP startet jetzt wieder ohne Fehlermeldung! 🙂

    Grüße Toast


  16. Kommentar von JGDigger

    Zufällig bin ich auf diese Site gestoßen.
    Ich bekam beim booten immer die Fehlermeldung: “… bitte Datenträger xxx in Laufwerk yyy einlegen” –> (abbrechen) (ok).

    Das ist jetzt endgültig (hoffentlich) vorbei.
    Ich habe die HIER beschriebenen Tips ausgeführt – und zwar folgende:

    1. Ich habe den Inhalt folgender zwei Ordner gelöscht (komplett) !
    – C:/Dokumente und Einstellungen/[Benutzername]/Lokale Einstellungen/ Temp
    – C:/Windows/Prefetch

    2. Ich habe absolut ALLE USB- & FireWire-Laufwerke “sicher” entfernt.
    Dies habe ich nach einem ReBoot ein zweites Mal gemacht.

    3. Ich habe die Datei “QuickTimeFavorites.qtr” gelöscht.

    —–

    Diese 3 Schritte haben mein “Boot-Problem” bis jetzt beseitigt.
    Ich muß dazu aber noch folgendes sagen:

    Ich habe einen “MEDION”-PC mit integriertem Speicherkartenleser.
    – Laufwerke “A,B” sind Diskettenlaufwerke (automatisch).
    – Laufwerke “C,D,E,F” sind Festplatten-Partitionen (automatisch).
    – Laufwerke “X,Y” sind CD-ROM & CD-Brenner (zugewiesen).
    – Laufwerke “Z” sind RAM-Laufwerke (zugewiesen).
    Willkürlich werden 4 Laufwerksbuchstaben für den internen Kartenleser zugewiesen.

    Testweise hatte ich mal einen USB-Kartenleser (4 Slots) angeschlossen.
    Diese 4 Laufwerke kann ich nicht mehr entfernen (wechselnde Buchstaben)

    Nunja – bis JETZT bekomme ich keine Fehlermeldung mehr beim Booten.

    DANKE für alle Tips


  17. Kommentar von frank

    ich habe ein problem mit meinem mp3 player wenn ich den “wechseldatenträger” öffnen möchte, zeigt mir eine Meldung an: “es liegt kein Datenträger im laufwerk G vor ….” ich würde mich über eine Rückmeldung oder beihilfe freuen. mit freundlichen grüßen FRANK


  18. Kommentar von JGDigger

    Tja – soviel dazu !

    Am 26.03. schien mein Problem gelöst zu sein. Heute kam die Fehlermeldung erneut (und gleich 4 mal beim booten). Hab’ inzwischen nix Neues installiert.

    Naja – muß ich meinen Rechner wohl auch platt machen.
    Ich glaub’, ich teste mal die Linux-Schiene 🙂

    cu


  19. Kommentar von PSeserko

    Bei mir trat diese Fehlermeldung (Betriebssystem W2k prof.)

    “a2guard.exe-Kein Datenträger”
    “Es befindet sich kein Datenträger im Laufwerk. Legen sie einen Datenträger in Laufwerk\Device\Harddisk2\DR7 ein.”

    auf, nachdem ich a-squared Anti-Malware Personal installiert habe, immer beim Starten von a2, oder eimnem seiner Elemente.

    Vom a2 Support bekam ich den Hinweis auf diese Seite.

    Nach dem Lesen der Kommentare hier hatte ich sehr schnell meinen Hama Cardreader 19 in 1 im Verdacht.

    Ich habe dann folgendes gemacht:

    1. Mit Linksklick auf “Harware sicher entfernen” die Laufwerke (in meinem Fall I, J, K, L) angehalten.

    2. a2 gestartet und es kam keine Fehlermeldung

    3. Den Cardreader wieder angaschlossen

    4. a2 gestartet. Fehlermeldung war wieder da.

    5. in der Datenträgerverwaltung nachgesehen, welches Laufwerk als Festpatte (Harddisk)2 aufgeführt wird. Es war I, das erste Kartenlaufwerk.

    6. Anschließend habe ich alle Kartenlaufwerke umbenannt, d. h. ich habe die Laufwerksbuchstaben um eine Stelle verschoben (Aus I,J,K,L ist J,K,L,M geworden).

    7. Rechner neu gestartet.

    8. Ich habe jetzt ruhe (hoffentlich für immer)

    ps


  20. Kommentar von Manfred

    Nach einigen Fehlversuchen (TEMP-Ordner, Prefetch-Ordner oder Umbenennen und Wiederzurückbenennen der Karten-Reader) half bei mir das Umbennen der Karten-Reader auf die letzten verfügbaren Laufwerksbuchstaben in der Datenträgerverwaltung.
    Vielen Dank für die zahlreichen Tipps, besonders der Kommentar von Peter.
    Tschau


  21. Kommentar von realyoda

    Hallo,

    erstmal Glückwunsch zum gelungenen Blog. Zum Fehler:
    Ich habe ein paar Szenarien durchgespielt und bin zu folgendem gekommen: Es liegt immer an einem Wechseldatenträger (-laufwerk), auf den sich nicht zugreifen lässt UND der als c:\ gemountet ist.

    Lösung: ummounten und c.\ nicht verwenden oder als c:\ ein garantiert beschreibbares medium (z.B. hd) verwenden.

    Bei mir war es ein interner Kartenleser (ja, mein Händler hat mich vor den Dingern gewarnt ;), der die Laufwerke c-f für seine Zwecke beschlagnahmt hat. Ich habe letztendlich nur den Slot im Gerätemanager deaktiviert, der auf c:\ verweist (ein MC-Leser, den ich sowieso nicht brauche) und seitdem ist ruhe.

    Ich vermute, der Fehler tritt auf, wenn eine Software den Test macht, ob C:\ vorhanden ist und dann automatisch voraussetzt, dass das DIE Platte schlechthin ist, um dort ihre Daten abzuladen, ohne weiter zu prüfen. Wie man an den teilweise seltsamen Tips sehen kann, können das die unterschiedlichsten Programme sein.

    So, viel Spass beim nachbasteln, liebe Kinder. Ich geh wieder ins Bett…

    yo


  22. Kommentar von Aloufin

    Danke!!! Bei mir hat die Kombi aus Euren antworten funktioniert. Endlich Ruhe 😉


  23. Kommentar von *g*

    danke
    !


  24. Kommentar von Marc Jentsch (www.marc-jentsch.de)

    Hallo,

    ich konnte dieses Problem dadurch lösen, dass ich einen im Rechner integrierten SD-Kartenleser im Gerätemanager abgeschaltet habe. Nun gibt es keine Probleme mehr.

    mit freundlichen Grüßen

    Marc Jentsch


  25. Pingback von error message DeviceHarddisk2DR12 | hilpers

    […] En hier zijn al een paar links waar ik ben geweest voor (niet) werkende oplossingen: https://www.workshop.ch/weitblick/index.php?p=41 http://support.microsoft.com/default…d=kb;de;330137 […]


  26. Kommentar von JAK21

    Hallo,

    super Tipp. Hat alles geklappt.
    Danke für die Info.

    ——————-

    ps: Die kleinen Fenster auf deiner Seite, die immer aufgehen, stören mich.

    ——————-
    Es sind die Kleinigkeiten.


  27. Kommentar von Tim

    Die kleinen Fenster sind jetzt weg.

    (Und für alle, die sich jetzt fragen, was das wohl für kleine Fenster waren: http://www.snap.com/snapshots.php)


  28. Pingback von Problemmeldung: Windows kein Datenträger ?!? - Digitalkameras und Bildbearbeitung

    […] einige Lösungsansätze für Dein Problem: https://www.workshop.ch/weitblick/?p=41 RSS feed for this post (comments) · TrackBack […]


  29. Kommentar von Daniela

    Danke, die Kommentare hier haben geholfen.
    Von meinem Cardreader den Laufwerksbuchstaben von G: auf V´: verändert -> Meldung weg!


Kommentar verfassen

Spam Karma 2